Tab for *.html files wont display


#1

I <3 atom … please fix this…


#2

Glad to hear you like Atom :smile:
But what are we looking at? Can you describe the problem?


#3

Take a look at the place where the tab should be for the html file opened in the editor.
There is no tab!! :smile:


#4

Ah… I thought you meant tab as in text indent :smile:

Is this true for just .html files, or are others also affected?


#5

so far its is html files only.


#6

what is most annoying about this is that the ghost tab (i think its an empty div, li element whichever atom uses) is not there and the adjacent tab say myJs.js ends up showing the html file :smile:


#7

I see, I’m getting the same thing, but it goes away when I run atom --safe and then open a .html file. This likely means there’s a package interfering with opening html files.

Does atom --safe also fix this for you?


#8

Im experiencing the same thing. Works fine in safe mode though.


#9

For me, the problem is fixed if I disable the autocomplete-plus package, then reload Atom and then open an html file.


#10

I tried disabling and even removing autocomplete-plus. It doesnt fix the issue here.


#11

Hmmm it seems to be a conflict between autocomplete-plus and another package, because it works just fine with only the autocomplete-plus package enabled


#12

I see that the autocomplete path is not working for me in strings within javascript… and autocomplete is also not giving good results… I have atome-tern installed…
Any this more we found out about autocomplete plus issues ?


#13

anybody has a solution ?


#14

If Atom in Safe Mode doesn’t show the problem, then one of your packages is causing the issue. @mark_hahn’s package-cop package is helpful in narrowing down which package is causing a particular issue.


#15

Hey guys… LinterHTMLHINT is the culprit…
I couldnt get my head around the package-cop package so I took a more brutish approach.
The below package helped me in a smallish way … “package list”


#16

As the author I feel free to say the UX for package-cop sucks. I’m planning on a major revamp to strip it down to just the offending package isolation. My package-list is cleaner.