Syntax Theme no longer works for .ts typescript files


#1

Something changed. HTML files still have color highlighting, but typescript ( .ts) files no longer have color highlights. I’m using One Light for both UI and Syntax. How do I get syntax colors back?


#2

Did you install the language-typescript package? Atom requires two things to do syntax highlighting: a language definition and a theme. Since you have a theme (it should be impossible to not have a theme :grinning:) the thing that is missing is the language package.


#3

I have atom-typescript installed. I did a search in the Install Packages section for language-typescript. Nothing with that name comes back. A package called language-typescript-grammars-only comes up, but it describes itself as a subset of atom-typescript.

Note that I used to have colored text for .ts files until sometime last week. Something changed. I don’t know if it was me, atom-typescript, or something else. I’ve tried changing settings in tsconfig.json, but have no idea whether that is the problem area or not.


#4

You may want to file an Issue on the atom-typescript package. They would have the most information on what is going on with their package.


#5

Thanks, I posted a problem statement in atom-typescript’s Bug section.


#6

With further poking around, I discovered that atom-typescript did not recognize coding errors that I purposely inserted. That led to finding on the Packages page that the version was “undefined”. I uninstalled atom-typescript, and re-installed it, and everything works fine. My hunch is that the last update failed in some way that did not generate a fail message, but nonetheless corrupted my copy of atom-typescript.


#7

thanks. I didn’t know it.