Syntax Highlighting


#1

Dear all,

Please excuse this simply question/problem… I am new to Atom.io. I would like to use it as an UML editor.

  • I have installed the PlantUML syntax extension
  • I open a UML txt file
    Nothing gets highlighted.

Can anyone assist? Thank you all in advance.


#2

Syntax highlighting in Atom is primarily based on file extensions. For the language-plantuml package those are: .pu, .puml and .plantuml. Anything else won’t be recognized as a PlantUML file and thus won’t get the syntax highlighting applied.


#3

Hello,

Thank you for your help. I have renamed my files .plantuml, but Atom keeps opening and appending .txt to the end. I have to then manually change from plain text to PlantUML.

What am I doing wrong?


#4

If you happen to be on Windows then chances are known file extensions are hidden and if you rename a file in the explorer, say file.txt, Windows lets you rename only the first part so it becomes file.plantuml.txt. You can google windows show known file extensions or something to find out how to change this.

You could now either keep manually setting the syntax to PlantUML like you did, or try renaming the files in Atom by right-clicking a file in the tree-view and selecting rename. That should let you change the extension as well.