Syntax highlighting for HTML, CSS, JS


#1

I’m new to Atom (3 months?) and like it a lot. I’m including my HTML, CSS, and JS in one file (I know, I know, but there’s a good reason for doing so), and have been happily coding using Atom. Everything (HTML CSS JS) has been beautifully and appropriately highlighted, and the code ran perfectly using Script.
I had to re-install Atom, and now find I have to choose between HTML, CSS or JS highlighting, which becomes annoying when I’m using JS highlighting and then have to change the "language selector’ at the bottom right to HTML in order to run the code. Is there any way to get Atom to revert to its original behaviour? Thanks… going slowly crazy here!


#2

Try going to settings (core or editor) and disabling tree sitter grammars, then restart Atom.