Symlink created, but Atom is not responding


#1

I love Atom. Sorry just had to say that. :relaxed: Anyway, followed the steps to create a symlink to have all my computers share the same packages etc, however when I start up Atom it hangs, and doesn’t boot up…

home directory:

This confirms the link is pointing to the ole DB folder so I am not sure what’s going on?

Any help would be fab!


#2

Is the destination folder on a local drive? Does it start without that link? Try emptying the folder.

BTW, you only need the packages folder and the init files in the remote folder. The rest is cache-like stuff and not needed. When I did the same thing you are trying I only had the links inside a real .Atom folder.


#3

Hey Mark!

Destination is Dropbox. I have a symlink pointing to my Dropbox folder. I merged two screenshots to illustrate:

Top image before that green line, that one is my User folder, with the alias point to the Dropbox file, and the second is what the files look like in my Dropbox folder. Seems like a similar process one would use for Sublime or anything for that matter.


#4

I tried the exact same thing and it didn’t work.

Then I used a real .Atom folder and linked the contents . I only symlinked the packages folder and individual files. I used that successfully for some time.

Then I experienced some slowdowns with dropbox. I switched to Unison which worked well but it would drop the connection on every reboot. So now I am using objectivefs, which costs money ($7/host/month), but it works perfectly for my needs. It is worth the $14/mo for me.