Switching tabs in Atom makes my Gulp watch trigger


#1

As the title says, when switching tabs in Atom my Gulp watch get triggered.

Anyone know how to fix this?


#2

Are you using https://github.com/atom/autosave or something ?


#3

I do have it installed, since it is a standard atom package, but it is not enabled.


#4
  • edit a file
  • a blue circle should appear on the tab
  • switch to another tab
  • if the blue circle disappear, then something is triggering a save on the tab when it loses focus

Strange that it happens though… as you say it is disabled…


#5

That does not happen.
It only happens (sometimes) when I switch tabs using cmd + 1 (or 2 or something)


#6

I do have no idea of what is causing this. Have you tried to run Atom in safe mode ?


#7

I no longer think it is a problem with atom, when I enter ‘git add .’ in the terminal it sometime triggers my gulp watch too.

Thanks for your help though :slight_smile: