Swapped Ctrl and Alt disables Alt Keybindings


#1

Using Gnome 3 on Manjaro I swapped Ctrl and Alt Keys, to use my OSX muscle memory. dconf settings:

/org/gnome/desktop/input-sources/xkb-options=['caps:ctrl_modifier', 'ctrl:nocaps', 'ctrl:swap_lalt_lctl']

Having this set up, Atom does not recognize any key commands involving Alt (the key that says ctrl on it). Ctrl commands (using the key that says alt on it) work fine though. Seems like Atom handles keystrokes at a lower layer than Gnome, bypassing the Gnome system settings.

Is there a way to fix this within Atom?


#2

See the recent blog post about the work we’ve done with keybindings and the Keymaps in Depth section of the Flight Manual for information on the Atom keybinding system and the tools available to you.


#3

Could you please specify the part(s) that lead me to solve the problem? I am not sure whether I missed an important part, but I think before Atom does not recognize me pressing Alt, it won’t help to (re-)configure any Keymaps with it.


#4

It looks like there might be some issues in Electron for keys on the Linux platform, such as https://github.com/electron/electron/issues/8216
(Electron is the project atom is built on top of; so if there’s a bug in electron, atom will have it. Electron is built on chromium. Wonder if it shows up in chromium).


#6

Looks like the same issue appears in Chromium Version 56.0.2924.87 (64-bit). That’s too bad.


#7

Maybe this is also a Gnome thing. Just noticed, that Alt did not work in Firefox either. Changend the xkb-options setting to ['ctrl:swap_lalt_lctl_lwin'] and now Alt (now being on the Win-key) works in Firefox, Chromium and Atom :smiley: