Support for osx 10.7


#1

I understand that atom is only for 10.8 version; however as many suggests I cannot upgrade to 10.8 because of having an old mac without a decent graphics card.
Does atom really need to be 10.8 considering I use all the tools and languages from nodejs, python, and chrome on my mac 10.7.5

If the answer is yes when can I expect a lower osx support? Seriously I just cannot justify to buy a new mac since it is working perfectly fine from virtualisation to full development with ssd


#2

You’re in trouble overall. The recently announced 10.9 has a slew of API updates that are going to make it irresistible to developers. I can certainly understand not wanting to upgrade for an editor, but given how fast users are upgrading to Apple’s now-free OS updates, I’m expecting many, many software applications to go 10.9 only. Within a year you’re going to find yourself frozen out from new software and updates to existing software.


#3

Duplicate of …

I don’t know what requires OS X 10.8 and there has been no official word from the Atom team as to what parts of Atom require it. But I also believe that it is a question of support. In order to support older versions of OS X, they have to keep a machine with the older version of OS X on it … and maybe they just don’t have one?


#4