Suddenly slow, even with --safe


#1

I’m not sure what I did. Atom is suddenly super slow. It takes about 5-10 seconds to just pick a file. 3 sec to write a line and so on.

This is what I’ve tried so far.

  • Installed the latest updated from the menu 1.7.4
  • Re-installed Atom from the website (without removing Atoms cache/config files) by replacing the application
  • Started it using --safe
  • Uninstalled themes and packages that might be slow (like linters)

Here’s the output from --profile-startup. No other errors in the console after I clicked around in the app. I’m using OS X.


#2

That’s not the output from the startup profile. If you notice, there is a message that states: “Switch to the Profiles tab to view the created startup profile”. If you do that, you’ll see something that looks like this (once you click on the “startup” file under the “CPU PROFILES” list on the left):

From there, you can dive in to the profile data and see what might be hogging all the time.

For a less technical readout, you can also call up the Timecop view:


#3

Here’s the output from recording after Atom has been loaded. Tried clicking on two files. Tried the profiler a couple of times and the put is always slow. It takes at least 1.5 seconds.

Tried starting Atom with --clear-state-store but same thing.


#4

The option is --clear-window-state.

That’s interesting. How large of a project are you working with? How much free disk space do you have?


#5

--clear-window-state worked! Thanks!

Free space: 30GB.
Number of files (find . -type f | wc -l) 14872. Another project (also rails) has 64853 and is fast.