Sudden massive lag due to automatic file tracking (?) [Atom 1.18] -- resolved


#1

I am aware that Atom has Git integration, and I have already linked my GitHub account to my Atom. Everything has been great so far, and I have been learning web development lately using Atom as my choice text editor.

Unfortunately, when I booted up Atom as per usual, there was a very obvious severe lag in its operations. I looked about for clues, and noticed this:

I suspect that this might be the cause of the problem. Yet, what has caused Atom to suddenly track all these files? It was still fine yesterday when I proceeded to sleep, but just became like this suddenly this morning. The lag is so bad that I can hardly continue to code on Atom at the moment, and it burns up the battery life like crazy. Some help, please?


GitHub integration has made Atom painfully slow
How do I make atom ignore all these irrelevant git changes?
#2

update: If it helps:

Since GitHub integration is a core package bundled with Atom 1.18, I think it may be the cause of my headache. Still no idea how to improve matters though…


#3

The files that are included might give us some clues. You should click on that and see if you can see any pattern. Does the folder you’re in have hundreds of thousands of files? Is it a node_modules/ folder that you forgot to include in the .gitignore?


#4

I’m afraid it isn’t as simple as a node_modules folder. Here is a segment of the screenshot that I got from doing git status on the terminal (while in the project directory, not in the root folder):

Clearly, many other files in the computer are being tracked, including things in the download section which are completely irrelevant to the project, or directories like the Pictures and Music directory. Why might this be so…?

Appreciate your help - Atom is still crashing on start up (with the current project folders)… :frowning:


Atom is crashing repeatedly while trying to load a bootstrap template
#5

The only thing I can think of is if you have a symbolic link somewhere that points to your root folder. If you find out what those dots are standing in for, you’ll find the culprit.


#6

Actually, following the dots really pointed to the root folder. Seeing that, I suddenly suspected that Atom has somehow made my root a git repository without my permission, making it track tons of folders.

So I ran this command on the terminal: rm -rf .git/ and things seem to have reverted to normal (for now). Would be great if the same thing does not occur again overnight…

P.S. Is there a way to mark a thread as resolved? New to the Atom Forums, and I don’t recall seeing this in the tutorial with @discobot :stuck_out_tongue:


#7

Hi! To find out what I can do, say @discobot display help.