Stuck on the html editor!


#1

I have been using atom for a while with no problems but today it opened with a html editor that looks like Chrome’s developer tools. I cant find a way of getting back to the normal Atom. Here is a picture


Console window/debugger opens whenever i start the Atom Application
#2

That is Chrome’s developer tools. A few questions:

  1. What does the error say? We can only see the back end of the stack trace.
  2. Does this happen when you open Atom from the command line with atom --safe?
  3. Does this happen when you close Atom, rename the .atom folder, and open it again?

#3

I have this same issue and i have not been able to fix it. What can i do?


#4

I keep getting this error every time i open the ATOM application. I open the application buy going into my applications folder and clicking on it.


#5

@Dandyvox Answering the same questions that @DamnedScholar asked above would be the first step in people being able to help :grinning:


#6

In order for us to help you, we have to be able to see everything you can see. That means that you have to go through the debugging steps for us and report back exactly what happens. If you don’t, we’re powerless.

@leedohm I see a bunch of /AppTranslocation/ paths in that stack trace. Do you have any experience with OS X translocating Atom? From what that article says, it sounds like an app residing in the Applications folder should not be translocated.


#7

Not specifically that, no … but I do know that people trying to run Atom from someplace other than /Applications (such as ~/Downloads as mentioned in the linked article) can run into problems.


#8

I’m not familiar with OS X Translocating, and I’m not sure if this is the error code: 32673f

I keep copying the entire error but the only thing that it pastes is (32673f)


#9

@Dandyvox If you haven’t installed the Atom application to your /Applications directory, you should start by doing that.


#10

I got the same issue on Windows and this The interface of ATOM look strange is the topic i created, but no one know this.


The interface of ATOM look strange
#11

@franklyndang Please stick with asking a question in the main thread (instead of making a duplicate), and please answer the questions I asked at the beginning of the thread.


#12

So sorry, i didn’t know this thread when i create my thread. So we will discuss on this thread, won’t we. Please help me close my thread, i don’t know how can i close it. Regarding ours issue, i look it’s still not resolve. And this issue appear on OS, with me is on Windows. I got it when my laptop was hard turned off. After turn it on, the Atom run like this

And i’m try to reinstall with the new source, but the result is the same.


#13

I have, but that doesn’t seem to help. I’ve done some research and apparently it has something to do with the new Sierra OS update 10.12.1.


#14

Please answer the questions I asked above.


#15

Where did you find this?


#16

I’m running Atom on Sierra 10.2.1 and we haven’t had any reports of people running into this problem that is specific to that OS revision.

If you’ve done this, have the paths changed? Because whenever I get stack traces, everything starts with /Applications but yours don’t. This leads me to believe that even if you moved your copy of Atom you’re still running it from someplace else.


#17

Oops! My mistake.

1/ I don’t really know . I just open and it appeared like i gave image before and the console appeared like below.
index.js:62 Error
at new Parser (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\node_modules\less\lib\less\parser.js:333:27)
at LessCache.module.exports.LessCache.parseLess (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\node_modules\less-cache\lib\less-cache.js:255:16)
at LessCache.module.exports.LessCache.cssForFile (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\node_modules\less-cache\lib\less-cache.js:286:20)
at LessCache.module.exports.LessCache.readFileSync (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\node_modules\less-cache\lib\less-cache.js:274:19)
at LessCompileCache.module.exports.LessCompileCache.read (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\less-compile-cache.js:36:25)
at ThemeManager.module.exports.ThemeManager.loadLessStylesheet (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\theme-manager.js:280:33)
at ThemeManager.module.exports.ThemeManager.loadStylesheet (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\theme-manager.js:256:21)
at ThemeManager.module.exports.ThemeManager.requireStylesheet (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\theme-manager.js:174:24)
at ThemeManager.module.exports.ThemeManager.reloadBaseStylesheets (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\theme-manager.js:236:12)
at ThemeManager.module.exports.ThemeManager.loadBaseStylesheets (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\theme-manager.js:231:19)
at new AtomEnvironment (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\atom-environment.js:279:19)
at module.exports (C:\Users\LifeStyle\AppData\Local\atom\app-1.11.2\resources\app.asar\src\initialize-application-window.js:22:19)
at setupWindow (file:///C:/Users/LifeStyle/AppData/Local/atom/app-1.11.2/resources/app.asar/static/index.js:82:12)
at window.onload (file:///C:/Users/LifeStyle/AppData/Local/atom/app-1.11.2/resources/app.asar/static/index.js:41:9)

  1. On Windows, i click into the icon to open it, not by command line

  2. This issue appear when my lap was hard turned off. At this time, it still gets this issue.


#18

You need to do that in order to test whether there are any packages that are causing the problem.


#19

I had removed Atom in my lap and try to re-install again. But got the same issues. This is what i got after double click into the Atom’s source from atom.io (93.728 KB)

I just use Atom about 1 or 2 months, but i like it. That’s why i’m try to follow this thread. Now, i use Notepad++ for wait Atom comeback.


#20

We need you to try running Atom in Safe Mode. To launch Safe Mode:

  1. Completely exit all instances of Atom
  2. Launch Atom from the command line, not the icon, with the command atom --safe