Struggling with native node libraries on linux, compiler issues


#1

Hi folks. I’m trying to use the Realm database in Electron. Unfortunately the Node module only has it pre-built for Node, so I tried using the electron-rebuild module which works a treat on Ubuntu 16.04, however, it fails miserably on 14.04. Problem is Realm requires “-std=c++14” and the most recent GCC prior to 16.04 doesn’t support that.

I tried rebuilding on 16.04 and then running on 14.04 but it complains that GLIBCXX_3.4.20 is not available. The strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBCXX command tells me GLIBCXX_3.4.19 is the latest on 14.04.

So I’m left wondering if I distribute an Electron app then is it not usable for people with older versions of linux that have outdated binaries. It seems Realm developers used the latest linux to do their work so that seems to force me too also, so I have the required libraries and tools to build, which then means users of my app must also? What is the user perception of this in the linux community, would they be annoyed that they have to upgrade their linux to use my app? (I know I would be.)

I’ve not tried it on Win or OS X yet and I suspect that will bring more pain. I did a little linux and Win32 native coding 15 years ago but mostly I do web development so I’m too much of a novice with this and feeling really frustrated and confused.

Thank you for any guidance!