Stopping tabs in HTML from creating tag?


#1

I’m using a package for Django called django-templates so that I have some django tag snippets available.

The problem is that a lot of these tags have tab behavior in them, i.e., tab between the different parts of the tag to enter additional names/data.

For example, if I create a block tag for Django:

{% block ${1}%} ${2} {% endblock %}

The problem I’m running into is when I’m at ${1} and I enter some text like the word “content” and hit tab to advance to ${2}, “content” then becomes <content></content> rather than simply the word “content.” Is there some how I can disable this behavior and only create tags for valid HTML words? It seems to do it for everything. I could type “blah” and it becomes <blah></blah> when I tab.


Snippets not working
#2

Do you have Emmet installed? If so, see the FAQ:


#3

I do have Emmet installed. Hmmm… that sucks. I like and use Emmet a lot.


#4

I think the issue is that both snippet and Emmet battle for using the tab key event.
This is not unlike snippet and autocomplete plus that also battle for that key.

There was a proposal to create a snippet mode when in the middle of a multi snippet input, and in that mode tab is reserved for snippet. I think that will help bot emmet and autocomplete plus issues.


#5

Makes sense. I’ll just deal with it for now. Now that I know what the issue is, it’s not a big deal. I just kept thinking something was wrong or there had to be a way around it.