Stop the line-drop


#1

Hi all,

On future releases could Atom stop dropping a line on ctrl + s (save), it would be useful (especially in PHP) to me!

Thanks :smile:
Trey


#2

Pretty sure this is actually intentional.

See http://stackoverflow.com/questions/729692/why-should-files-end-with-a-newline
for more details.


#3

You can also tweak this behaviour right now. Just look for the Whitespace package in Settings and flip some checkboxes.


#4

As @braver said … specifically turn off the Ensure Single Trailing Newline setting:


#5

Thanks @braver and @leedohm :slight_smile: