Stop enter key from expanding snippets (only use tab key)?


#1

I want the enter key to only ever add a new line in the editor and not expand snippets. I want to use only the tab key to expand snippets. How do I do this?


#2

You can change this in the settings for autocomplete-plus:

EDIT: Although this will change the keybinding for all autocomplete, not just autocomplete for snippets.


#3

As far as I know, Snippets should never be expanded with enter unless you manually changed this in your ~/.atom/keymap.cson:

However, autocomplete-plus will add suggestions for snippets if you have the autocomplete-snippets package enabled. If you only want the completions when you press tab, make sure autocomplete-plus is configured to do so. Change the 'Keymap for Confirming A Suggestion` setting to tab only:


#4

Thank you, this is exactly what I needed.


#5

Link to updated options (New option: tab always, enter when suggestion explicitly selected)

https://discuss.atom.io/t/disable-enter-keybinding-for-autocomplete-snippets/28644


#6

One step solution


This problem is caused by the package emmet.
I am also facing the same problem, so I thought to disable the third party packages to find who is causing the problem. So after disabling emmet the problem is gone.