Stop adding one space before a new line


#1

Hi here, I’m new to Atom.
I don’t know why Atom automatically adds a single space character before every new line. Are there any ways to stop that?


#2

That should not happen. Try opening Atom with the command atom --safe and see if it still happens.


#3

Thank for your suggestion! But it still happens.
You can see it on this link.
You should use 2x speed for better experience :sweat_smile:


#4

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Do you have the status-bar package disabled?

You may want to file a bug on the language-php package.


#5

Thank you, @leedohm!
I have done debug by using your guidelines and it still happens.
The problem is Atom does not reset the cursor’s position to 0 after closing the Docblock but keeps indenting at 1.


#6

So it only happens after a docblock? BTW, you need to answer @leedohm’s questions to get proper help.


#7

DocBlock is the thing - auto-indent assumes you want to indent each new line the same as the last one (for most code it adjusts nicely once you start typing to show Atom what you’re doing). Once you delete the space, it should stop happening for new lines after that.