Split Pane Not Working


#1

Trying to split the panes in Atom, with cmd-k right, nothing seems to happen. No errors in the console either.

Just wanted to raise the issue.

Great work guys!


#2

Aha! It wasn’t immediately obvious. One has to do cmd-k, then the arrow for the direction you want. Awesome.


#3

They should really fix it to be Cmd-K + -> not Cmd K ->, it was confusing for me too.


#4

Wow yeah, that wasn’t clear at all. It’s more CMD + K,


#5

This is weird, it doesn’t work for me!


#6

Super confusing and no UI to suggest it’s waiting for a key.

Something like a box in the middle with “press one of :arrow_up: :arrow_down: :arrow_left: or :arrow_right:” would have helped.


#7

Yep @hunterloftis that would be cool :smiley:
Does the keymap work for you though?
Nothing will do for me bummer have to do it through the command palette every time!


#8

Ok guys all sorted now :smiley:
Add some keybindings issues!


#9

Yeah, this is super confusing. I gave up on this as not working and was wondering why they chose the awkward combination of those three keys. I was just using the split commands in the command pallets. Now with this clarification, it’s working for me.


#10

This doesn’t work for me either.

System:
2011 MBP 13" with 10.8.5

No error, nothing in the console log. Very strange.
Is there a relatively easy way to debug this?


#11

Yes, you can see if the keys are working as expected by using the keybinding resolver which can be activated by the command palette or ⌘.


#12

Is there any other any hotkeys like this? May be nice to add a note because it’s so different.


#13

For further clarification: release cmd-k before pressing an arrow key


#14

I was having a related problem with split panes not working, but instead I was unable to switch pane focus.

⌘ + k, ⌘ + left/right/up/down
Focus pane left/right/up/down

seems to be the correct command but it didn’t do anything. To describe in words what I did, I pressed the ⌘ key and at the same time without letting it go I pressed the left/right/up/down.

Might it be another package intervening the correct behaviour? Or is it that my atom is not updated? I tried checking both but not sure if It did anything to solve the issue… for ur time :slight_smile:


#15

Try opening the Keybinding Resolver (Cmd+. on OS X) and then typing the key combination to see what Atom thinks you’re pressing.


#16

That is so cool.

Well, it thinks I am doing a

editor:move-to-end-of-screen-line

how do I disable that?

Also, how do I copy paste (select) from that little pane for Key Binding Resolver?


#17

Duh, another misunderstanding. Not sure if it was written unclearly but I didn’t understand what it wanted. It wanted the prefix cmd-k and then cmd-right or cmd-left. Now it works! Though I learned that cmd+. shows me what atoms thinks I am typing. Thanks.


#18

As ahuwaa said, press cmd-K then release all, then press a direction (ie. right). No need for cmd-direction.

(I’m only posting this because clarity has not been added yet for the user, and it was confusing for me as a new user.)


#19

Is there a ‘pane:split and move left/right/up/down’ keybinding or way to make it work? It took me a while to get ‘pane:split and copy active pane …’ but I don’t care about copying it, I want to move the entire pane. Anyone have suggestions?


#20

Since v1.9 Atom has had drag-and-drop pane management:

You may find it easier than dealing with the commands.