Spell checking Win 7


#1

It seems the default spell checking does not work on win7, even for plain text. I do have the AsciiDoctor packages installed but the spell check and forums say its compatible with AsciiDoc.

Is there some trick to getting this to work?


[SOLVED]Search doesn't work
#2

What are you even saying?


#3

Seems pretty straight forward.

Spell check does not spell check…


#4

In order to figure out what’s happening, we need to see if we can isolate the variable that’s causing the failure. @danPadric is the only one I know who uses Windows 7 here.


#5

Hello… did you call me :wink:

I have tried on several occasions to get this package to run… no joy. Simply put - I have no idea how it should look like if it is actually active (except for the ~ lines under the text). Do you know of any way to see if the package is active / toggled on? How does it look on other systems?

A complication is that my computer is not set for a “standard” English. The documentation does not state where to look for to see if a “dictionary” is loaded where it expects it to be.

It would have been nice if the guys supplied a standard dictionary with EN-GB and EN-US. Unless we can link dictionaries that work with browsers. I even have my English & local language spell-checked on Firefox.

JUST please do not only supply a standard US language…
those spellings drive me crazy. :crazy_face:

It would be real nice if this spell-check could work.

Cheers.
dP


#6

When I open a plain-text document, everything that’s not a dictionary word is underlined with a dotted red line.

A complication is that my computer is not set for a “standard” English. The documentation does not state where to look for to see if a “dictionary” is loaded where it expects it to be.

I don’t think that should be a problem, but IDK. I don’t pay attention to spell check behavior except to disable it when it gets too obnoxious. I don’t need help spelling things unless I’m writing in another language.


#7

Under settings, if the package shows the Disable button then it should be active.

My system is standard English and it still doesn’t work.

Checking the Use Locales checkbox and setting en-US doesn’t work either. The language and region is also showing as set under Region and Language settings.


#8

#9

I don’t know what toggling spell check is supposed to do but nothing happens when I select it.


#10

Even I use Windows 7 what I wanted to hear is how to replicate the problem.


#11

Perhaps try the following -

  1. Ensure the spell-check package is activated.
  • If not activated yet - activate the package.
  • Restart Atom to see the configuration settings.
  • Set all the configuration settings.
  • Restart Atom again; the settings are not active otherwise…
    Not sure why this behaviour.
  1. Type into a text file (myFile.txt) what @mitm showed in his last picture.

  2. Toggle the spelling check (via Ctrl+Shift+p).

  3. Are there any wavy underlining?