Spell checking not working despite all my efforts


#1

Hello everyone,

I apologize for bringing out this issue but I promise I have tried everything I could find and I am still unable to make spell checking working in Atom.
I am writing a document in Latex and the misspelled words are not underlined (but while typing, I get auto-completion suggestions).

I am using Manjaro Linux (which should be similar to Arch) and the last Atom version.
In the settings of the Spell-check package, I have added this in grammer: text.tex.latex
I also have hunspell installed and tried the suggestion of this post: https://discuss.atom.io/t/spell-check-i-cant-get-it-to-work-at-all/28708/4?u=alessandro, which returns true.

Can anyone suggests anything?
Thanks a lot


#2

If you’ve exhausted all steps in the documentation, the maintainers of the package are more likely to be able to help you than us.


#3

How many dictionaries have you got (use hunspell -D to check for hunspell)?


#4

Oh I think you put me on the track … This is what it returns :

Can’t open affix or dictionary files for dictionary named “en_US”.