Spell check problems


#1

I have 2 problems with spell check:

  1. No problem in English, but when I write in Greek every word is underlined although these words are correct. I have installed Greek myspell dictionary. But when I open with a text editor the Greek dictionary, Greek characters look like strange symbols. Maybe this is the cause of the problem?
  2. I added
    ‘atom-text-editor’:
    ‘alt-cmd-c’: ‘spell-check:toggle’
    in keymap.cson, restarted, but toggle does not work.

~ $ hunspell -D
SEARCH PATH:
.::/usr/share/hunspell:/usr/share/myspell:/usr/share/myspell/dicts:/Library/Spelling:/home/hk/.openoffice.org/3/user/wordbook:/home/hk/.openoffice.org2/user/wordbook:/home/hk/.openoffice.org2.0/user/wordbook:/home/hk/Library/Spelling:/opt/openoffice.org/basis3.0/share/dict/ooo:/usr/lib/openoffice.org/basis3.0/share/dict/ooo:/opt/openoffice.org2.4/share/dict/ooo:/usr/lib/openoffice.org2.4/share/dict/ooo:/opt/openoffice.org2.3/share/dict/ooo:/usr/lib/openoffice.org2.3/share/dict/ooo:/opt/openoffice.org2.2/share/dict/ooo:/usr/lib/openoffice.org2.2/share/dict/ooo:/opt/openoffice.org2.1/share/dict/ooo:/usr/lib/openoffice.org2.1/share/dict/ooo:/opt/openoffice.org2.0/share/dict/ooo:/usr/lib/openoffice.org2.0/share/dict/ooo
AVAILABLE DICTIONARIES (path is not mandatory for -d option):
/usr/share/hunspell/el_GR
/usr/share/myspell/hyph_el
/usr/share/myspell/el_GR
Can’t open affix or dictionary files for dictionary named “en_US”.

Other settings:
Locales: el-GR, en-US
Locale Paths: /usr/share/myspell
My OS is Gentoo
Atom: 1.23.3 x64


#2

With same setup in Windows 10 everything works fine. :neutral_face:


#3

Do you use a font that supports Greek characters?


#4

I don’t have a problem with other Grrek letters except the Greek Myspell dictionary which I downloaded. It says encoding is ISO 8859-7. My systems default encoding is UTF-8.


#5

Although it does not seem very correct to me, I converted myspell Greek dictionary from ISO-8859-7 to UTF-8 and both problems are resolved.