Spell-check doesn't seem to work for me


#1

https://atom.io/packages/spell-check which is pre-installed, and caused hi cpu issues in the past on mac, doesn’t seem to work for me. No wavy red line, no response to the ctl/click menu (mac os x mav latest).

I do note that this is in my config file under global
’spell-check’: {}
Does that turn it off? It is enabled in Settings.

Should I uninstall/reinstall? How? … in the Settings it just enables/disables, doesn’t toss it and let me reinstall it.

Thanks!


Spell check not working
#2

It doesn’t normally do a red wavy line (but I’ve written a package for that :grinning:), but …

  1. No, that doesn’t turn it off … it just means that there aren’t any non-default settings
  2. I haven’t needed to uninstall/reinstall any package since most packages don’t really maintain much, if any, state
  3. What state packages do keep is almost always in ~/.atom/storage, so what you could do to destroy any borked state is:
    1. Completely exit all instances of Atom
    2. Execute mv ~/.atom/storage ~/.atom/storage-backup from the command line
    3. Launch Atom again
  4. If you really think you need to reinstall the code, you should uninstall and reinstall Atom itself (or, at least, that’s the easy way)

If step #3 fixes things, then you might want to zip up the storage-backup directory to help the Atom team debug what went wrong.


#3

Tried the storage stunt and it worked, also installed your wavy line package, thanks!

So who should I send the ~/.atom/storage-backup zip to?

Oops, CPU hi again. But at least the functionality is there. And the cpu reduced w/in 30sec. We’ll see.


#4

You can send it to support@atom.io. You should probably open a bug on the spell-check package and reference that you sent in a ZIP and this topic so that they have all the information.

Thanks!


#5

doing steps #1-4 did not work for me.
i am using atom 1.17.2 x64 on osx 10.12.4.
any other ideas?


#6

Does spell-sheck not work at all for you @jovo or only for particular types of files? E.g. if you open a new plain text file and type “hiii”, does spell check not highlight that for you?


#7

good point! i should clarify!
i does not work for .tex files.

i changed my "grammars’ to say this:
source.asciidoc, source.gfm, text.git-commit, text.plain,
text.plain.null-grammar, text.tex, text.md

thanks!


#8

Thanks for the details - I went ahead and installed the language-latex package and it looks like the grammar scope is text.tex.latex?


#9

Thanks for responses!


#10

:tophat: