Spawn cmd.exe ENOENT


#1

When I try to use any of the TERMINAL packages (things that let you run commands from within Atom), all they do is return the message “spawn cmd.exe ENOENT” - since all 3 of the Terminal packages I’ve tried have produced the same message, I’m wondering if this is a more general problem


#2

That means you are missing some file or directory in your setup. You should post this as an issue on one of the packages and they’ll probably be able to tell you what you’re missing.


#3

What OS are you on?

On Windows this can sometimes be caused by a bad value in the COMSPEC environment variable.


#4

I think I’m good. I switched to the Terminal Panel plugin and it works fine. DOS.


#5

I’m pretty sure Atom doesn’t run on DOS, whether of the MS-, PC- or DR- varieties :laughing:


#6

Ha. I meant windows 7.


#7

Same issue here, fresh install of Atom 1.4.3.

Fixed by adding “C:\Windows\System32” into %PATH% variable. :wink:
Also starting Atom from cmd line in the project directory with dot as a command line parameter (current directory), eg. “>atom .” opens atom in the project directory, not in atom://config or atom://about space.


#8

I could not find the solution to this problem.
I am getting the errors as-

spawn C:\Windows\system32\cmd.exe;C:\Program Files\PostgreSQL\9.5\bin ENOENT

@radkoa I followed what you did but still I am stuck