[Solved] Why is not Atom managing properly github built-in package update?

Is there a way to force that update? Why Atom does not show the update?

Thank you so much. :slight_smile:

Built-in packages don’t update themselves like community packages do. When the next version of Atom is released, we’ll get all of the community packages included in that version. The 0.26.0 version of the github package will be shipped with Atom version 1.36.0, which is the next beta version once 1.35.0 hits live.

If you want to override the github package with the most recent version, Atom provides native support for manually installing whatever packages you want to use.

Yes, you are right, the warning I was receiving about github package deprecation was due for a strange reason, (maybe sync-settings package has caused it) I had github core package installed like a community package.

What do you think? :slight_smile: It is sync-settings properly handling github core package?

Okay, I want you to start at the beginning and explain everything to me step by step. Your gif didn’t mention anything about a deprecation method or a package like sync-settings.

I’ve never used sync-settings, so I don’t have experience with how it should behave. I do, however, know a lot about Atom and can read JavaScript, so if you give me a good enough description of each step of the problem, what you’ve done, and the effects you’ve seen, I can follow along and perhaps provide insight on what’s going on.

Well, I did not anything specially strange, I just followed its docu.

As you can see if your read it … You must use a Gist on github to store config files. I’m doing exactly that in my desktop/workstation PC.

When I did restore those settings in my laptop PC I did get a popup warning me that cannot disable github plugin (a bit strange, since github is a built-in package it should not be modified …). But that’s all, it did by itself, I promise … xdd

Does your Gist mention anything about github?

{
“name”: “github”,
“version”: “0.23.3”
},

And looks like right, this is the version according to you.

Built-in packages don’t update themselves like community packages do.

The point is … why would need sync-settings disable github built-in package?

Might this be related with dependencies, perhaps?

I’m guessing that’s telling you that it can’t be deleted, not that it that it can’t be disabled. Which is true for all core packages.

Only you or the sync-settings maintainer can be reasonably expected to know the answer to that.

Why is a core package listed in the Gist you’re using for sync-settings? Since it causes the package to try to do weird things, it seems like the obvious answer would be to remove that entry.

Certainly you were right, removing that entry from my gist is working as expected. I think I’m going to link this conversation into the issue.

Thank you guys! :slight_smile:

PS
Should I not mark this post as [Solved]? Perhaps Is this optional?

If you want to, you can.