[SOLVED]Unable to use Git with Atom after switching from GitLab to GitHub


#1

Hello everyone. I can’t pull or push anything with Atom on GitHub. This happened when I switched my repo from GitLab to GitHub. Before this operation I could push and pull using the Git “plug-in” in Atom without problems. What you do suggest me to do?

Thanks in advance.


#2

With no further information, my initial conjecture is that this could be caused by your local repository still pointing at GitLab. Please open up a command line (process-palette is also quite good for this if you want to do things from within Atom), navigate to your repo folder, and use the command git remote -v. If some or all of the remotes are on GitLab, that’s likely the cause.


#3

image

Hello, the command didn’t work… This is the error I get when I try to pull and push


#4

Okay, but what happens when you use git remote -v?


#5

immagine

This is the message I get. I noticed now the misleading “didn’t work” on previous message. What I meant was: it didn’t solve the problem.

PS: GitKraken, even after the switch from GitLab to GitHub is working fine tho!


#6

If it were a problem-solving command instead of a finding-information command, I would still want you to tell me as many specifics as possible. That’s the only way this can happen without me logging in to your computer.

I don’t know how to solve it. I do notice that you only have the one repo and you’ve just started using GitHub, so perhaps your credentials aren’t set properly? However, that would likely make GitKraken also not work, and since it does, I’m at a loss. I would encourage you to make a second repo at some point and see if you can push and pull on that one. That will tell you if the error is localized to the repo or Atom.


#7

@MC23 not sure this will work on Windows, but since you’re using MinGW, it might. Can you check the output of ls ${HOME}/.ssh/ and see if there’s a file called “id_rsa.pub” in there? If so, add the contents of that file to your SSH keys on GitHub. You can display the contents by running cat ${HOME}/.ssh/id_rsa.pub.

If that doesn’t work, someone with better Windows knowledge needs to step in.

My reasoning: From the error message, it appears to me that the SSH key of this user has not been added to their github acount.

I don’t know where to find that key on Windows though. And it’s very possible that GitKraken uses a different key (e.g. an internal one) than whatever mechanism Atom uses. Which would explain why it’s possible for GitKraken to succeed, whereas Atom fails.


#8

On Windows, there should also be a folder called .ssh/ inside the user folder.


#9

Hello, I didn’t have a SSH key on my PC (I actually had one called “known host”, but think I’ve never used it). I’ve now generated the SSH key pair and added the public one to my GitHub account, I’ll reboot and let you know if this has solved something.

EDIT: yay! This fixed the problem, I probably delete the key by mistake :s, I’ll perform the same operation on my other computer.

Many thanks again!