[SOLVED] Unable to get any support

Hi,

A few days ago I posted this issue on Atom. I haven’t received any response. The silence is deafening! I read the code of conduct. I don’t believe I have violated any of the conditions therein (if I have please let me know). The issue is stated as accurately and with as much detail as I think is relevant. Please let me know if support really functions on this forum or if it is something I have done wrong?

Thanks,

Hello.

Your problem seem very technical and specific,
but nothing in your wording violates conditions.
This forum is manned by volunteer users which may not know how to help.
I run on Windows and would not dream making a mod to how Electron works.

You have other avenues which may get attention from maintainers:

  1. Atom project issue
  2. Slack

Someone may ask you to do some procedure that is mentioned in the manual.
The manual is here (you probably know already):
https://flight-manual.atom.io/

Removing Atom completely from your system might be helpful.
The trouble is that it is not so straightforward on Windows, so I guess Linux will be tricky too.
I do not know where it is documented how to remove Atom completely.

One diagnostic method is to start Atom in safe mode.
Have you tried that yet?
That will be the first question that comes up when formally registering an issue.

Good luck.

Thanks a lot for your response. I made a similar request on the Linux forum and finally received this simple answer that worked immediately.

It seems that Atom’s per-user configuration folder is ~/.atom; try, with Atom closed, deleting or moving that out of the way, [c]mv ~/.atom ~/.atom.orig[/c], and seeing if the problem persists.
[/quote]

Anyway your suggestions are much appreciated …

Good to hear you got an answer that helped.
I would not have guessed that solution would work.
Thank you for returning here with your feedback.

Below are some of the files and folders that are in the configuration folder you speak of.

D:\AtomAlpha\.atom>dir

Directory of D:\AtomAlpha\.atom

2020/01/19  12:42    <DIR>          .
2020/01/19  12:42    <DIR>          ..
2019/12/10  17:56    <DIR>          packages
2020/01/18  15:41             4,326 config.cson
2019/12/07  22:46            10,998 init.coffee
2020/01/03  08:40             1,134 keymap.cson
2020/01/02  11:49             1,127 snippets.cson
2020/01/03  11:13             7,167 styles.less

Try to restore those from the backup you made (assuming you did so).
Try running Atom again.
The problem was in the cached files if you have Atom up and running normally.

Else if the problem re-occurs, the the issue is with the customization or external packages.
For that case it is best to start checking what is set in the config.cson and init.coffee files.
Thereafter the packages needs to be cleared.

Do you require assistance or are you sorted?

1 Like

I’m sorted. Thanks very much for your help and the additional comments in case similar issues arise in future …