SOLVED: Tried installing my first package but getting an error


#1

Installing “atom-ftp-editor@0.5.0” failed.Hide output…Failed to install atom-ftp-editor because Git was not found.

The atom-ftp-editor package has module dependencies that cannot be installed without Git.

You need to install Git and add it to your path environment variable in order to install this package.

You can install Git by downloading, installing, and launching GitHub for Windows: https://windows.github.com

Run apm -v after installing Git to see what version has been detected.

After running the apm -v command I get this output:

apm 1.4.1
npm 2.13.3
node 0.10.40
python
git
visual studio

I’ve closed down and ran atom twice now as administrator with same thing happening. I’m trying to install the package from within Settings menu, package name: atom-ftp-editor.

Thanks for your time,
BluTiger


#2

SOLUTION:

I only had one of the folders for Git in PATH, not all of them.

Adding the following to my Windows 10 PATH environment fixed it all up nicely. :smile:
C:\Program Files (x86)\Git\bin;C:\Program Files (x86)\Git\cmd

Got the package installed and working beautifully with the required “hello world” statement.