[Solved] Scrollbar not appearing in main files


#1

Hello all,

I am a recent user of Atom and think it is a great tool!

However, I have been experiencing a problem that keeps bugging me: it seems that the scrollbar does not appear for the .C and .h files. As you can see on the screenshot below, it is there for the Project and Settings tab (and it works also for the ‘Project Find Results’ tab) but not for the C file shown, which can be annoying when I have large files.

I looked in the Settings and couldn’t find anywhere how to make it show up.

Would anyone know how to solve that problem?

Thanks a lot in advance!


No scrollbar on certain files
#2

On the right-hand side of the status bar, there’s an indicator of the active language. Click on that and you can change the active grammar. I want you to change the grammar to something else, then back to C and verify that, for the same file, without changing anything else, the scrollbar appears and then disappears based on the active grammar.

Do you see a scrollbar when the grammar is C++?

Do you have anything in your styles.less that targets .scope.c?


#3

Thank you for your quick reply!

I am not sure to understand what the ‘status bar’ is :frowning:

What I can tell you is that I have a similar problem if I open a .cpp file

As for my styles.less, it is as follows:

/*
 * Your Stylesheet
 *
 * This stylesheet is loaded when Atom starts up and is reloaded automatically
 * when it is changed and saved.
 *
 * Add your own CSS or Less to fully customize Atom.
 * If you are unfamiliar with Less, you can read more about it here:
 * http://lesscss.org
 */


/*
 * Examples
 * (To see them, uncomment and save)
 */

// style the background color of the tree view
.tree-view {
  // background-color: whitesmoke;
}

// style the background and foreground colors on the atom-text-editor-element itself
atom-text-editor {
  // color: white;
  // background-color: hsl(180, 24%, 12%);
}

// style UI elements inside atom-text-editor
atom-text-editor .cursor {
  // border-color: red;
}


#4

It’s the bar at the bottom edge of the window.


#5

Oh, I see it now, thanks!

Unfortunately, I still don’t see the scrollbar if I change to C++ or anything else
I also have the same problem if I open a python file

How do I target .scope.c in styles.less?

Thanks!


#6

Okay, so your previous assessment of the problem was incorrect. It is not limited to C-language files. Are there any files where you do see a scrollbar? Do you see a scrollbar when you open Atom from the command line with atom --safe?

How do I target .scope.c in styles.less?

There are plenty of great tutorials on CSS selectors out on the web.


#7

You are correct, I don’t see a scrollbar for any files (I just hadn’t tried any other types then)

And no, opening atom --safe does not solve the problem


#8

I find it strange that the scrollbars you do see are so white and blocky, especially since we’ve ruled out the chance of it being a style sheet conflict. I’m using the same theme and my scrollbars are thin gray lines with no background. You should open the developer tools (View -> Developer -> Toggle Developer Tools) and look at them to see how they’re being represented in CSS.


#9

The reason they are so white and blocky is that I saw on other posts on this website that other people had problems with their scrollbars on Mac and that they had to go to System Preferences->General and then check the box Show scroll bars -> always.

I kept that for the screenshot because it emphasized them pretty well. With my regular settings however (Show scroll bars -> Automatically on mouse or trackpad), I have them as you said (thin gray lines with no background).

In that latter case, my developer tools show the following for the scrollbar:

58 PM


#10

Update Atom - this was fixed in 1.19.6.


#11

Perfect, that solved the problem!

Thank you both for your help!

PS: I encountered the issue https://github.com/atom/atom/issues/13804 but the fix was given at the end