[SOLVED] PDE Filetype Grammar Changing Automatically to C++?


#1

I have a package for processing.org, *.pde files installed (processing-language).

when i create a new file with a pde extension it recognizes the grammar properly. when i reopen the file it changes the grammar to C++.

If I use “Auto-Detect” in the grammar picker it will change it back to Processing.

why would Atom be changing it to C++ on it’s own?

thank you.


#2

I can’t replicate that. It sounds to my noobish ear like there are two grammars that both list pde in their file extensions, but I don’t know why language-c would. You should take a look in its dictionary just to see. If you don’t find anything there, try disabling language-c and see if the behavior persists.


#3

disabling C++ does fix it for Processing files. but without it enabled my Arduino sketches aren’t picked up as C++ files. lol

you mentioned the dictionary, where is that located?

thank you for the reply.

edit: i think it might be an issue with Platformio. I’m going to ask in their forum.


#4

Upon looking everywhere, the language-c package appears to be built into the binary file. So nevermind. It’s almost certainly not that.


#5

reply in case anyone else has this issue.

Platformio was the culprit.

For more info check the following post in Platformio’s forum: