[SOLVED] Open files from FileZilla


#1

Hello,

I’m trying to set Atom to default file editor programm in FileZilla. My os: Windows 10.
All I have to do is to set the application path into a setting field. I found that the path to open Atom is this one on my system:

C:\Users\Jojaba\AppData\Local\atom\Update.exe --processStart atom.exe

But using this command just opens Atom and not the file I would like to edit with. I guess I should add an argument (I tried -file argument without success) to the command.

A clue?
Thanks in advance. :blush:


#2

Well, found a command that works but this is not the best one because depending on Atom version:

C:\Users\Jojaba\AppData\Local\atom\app-1.2.1\atom.exe

I would prefer using the command I pasted in my first message… Any advice?

[edit]
The problem when you use this command is that when you work on Atom in local and close the application, when reopening, you have the fie you edited from FileZilla that appears and not the file syou worked on before. This is not a good way to handle this…
[/edit]


#3

You should be able to just add the file name after the command to launch the file in Atom. So:

[whatever the command is] filename.txt

#4

Thanks for that reply leedohm :grinning:
OK for that.
But how can I get the file name in FileZilla?
I guess I should ask on FileZilla forums…


#5

Sorry, that part I don’t know … but I’ll see if I can dig out the information later today if you don’t find it first.


#6

Well, found a command that works but this is not the best one because depending on Atom version

The cmd in bin folder alwais point to last version, maybe this works

C:\Users\Jojaba\AppData\Local\atom\bin\atom.cmd

#7

Hey! That’s it!
Thanks a lot jeancroy!

Tested your command in FileZilla 3.14.1 on Windows 10, 64bits with success (I guess this will work on other Windows versions). The file opens in Atom in a new tab if there are other buffers already opened even if Atom is closed. Exactly what it should do :wink:

Explanation for those who wants to change the default file editor in FileZilla:

  1. Go to Edit » Settings menu

  2. Click on File editing in the left pane.

  3. Check the Use custom editor radio button and paste this into the corresponding field: C:\Users\Your_user_name\AppData\Local\atom\bin\atom.cmd or the path to the atom.cmd file if using another Windows OS.

  4. Check the radio button Always use default editor (or not if you wnat to associate each file type to another editor…)

  5. Check the checkbox Watch locally edited files and prompt to upload modifications Then click OK

Thanks again for your help! :grinning:

PS: how can I set this topic as solved (I’m not familiar with “Discuss” forums, sorry)?


#8

Geat instruction, this screen is a nice addition I think.


#9

Indeed! Thanks.


#10

Hi!

I have set filezilla as shown above, and though the file is actually opened in Atom, Atom stays in background. Actually it flashes in the task bar letting you know there is an update, but it doesn’t come to foreground as other editors do, what is very uncomfortable.

Is there any option in Atom to force it to come to foreground when a new file is opened?


#12

This worked like a charm for me! Thank you