[Solved] New Package Installs/Updates Generates errors


#1

On Every Package I have tried to install on Atom on version 0.144 has resulted in nearly identical errors, tried uninstalling and doing fresh install on new OS on 10.10 & 10.9… still generates same errors.
Hope I have given enough information that I can get some help with this.
Versions:
OS: Mac 10.10.1 (14B17)
DJ$ apm -version
apm 0.109.0
npm 2.1.7 <-- updated this (REF https://github.com/npm/npm/issues/6613#event-190394145)
node 0.10.32
python 2.7.6
git 2.1.3

Error:

npm ERR! Error: Attempt to unlock /private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/d-114108-2895-17nobqm/package.tgz, which hasn't been locked
npm ERR!     at unlock (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/lib/cache.js:1304:11)
npm ERR!     at cb (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/lib/cache.js:866:5)
npm ERR!     at /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/lib/cache.js:883:20
npm ERR!     at /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/lib/cache.js:1282:20
npm ERR!     at afterMkdir (/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/lib/cache.js:1013:14)
npm ERR!     at /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/mkdirp/index.js:25:29
npm ERR!     at /Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/node_modules/mkdirp/index.js:37:53
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 14.0.0
npm ERR! command "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/DJ/.atom/.apmrc" "install" "/private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/d-114108-2895-17nobqm/package.tgz" "--target=0.18.0" "--arch=x64"
npm ERR! cwd /private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/apm-install-dir-114108-2895-jycrn7
npm ERR! node -v v0.10.32
npm ERR! npm -v 1.4.4
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/apm-install-dir-114108-2895-jycrn7/npm-debug.log
npm ERR! not ok code 0

attempt after update to npm 2.1.7

npm ERR! addLocal Could not install /private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/d-114108-3031-sffnv0/package.tgz
npm ERR! Darwin 14.0.0
npm ERR! argv "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/atom-package-manager/.apmrc" "--userconfig" "/Users/DJ/.atom/.apmrc" "install" "/private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/d-114108-3031-sffnv0/package.tgz" "--target=0.18.0" "--arch=x64"
npm ERR! node v0.10.32
npm ERR! npm  v2.1.7
npm ERR! path /Users/DJ/.atom/.node-gyp/.atom
npm ERR! code EACCES
npm ERR! errno 3

npm ERR! Error: EACCES, mkdir '/Users/DJ/.atom/.node-gyp/.atom'
npm ERR!  { [Error: EACCES, mkdir '/Users/DJ/.atom/.node-gyp/.atom']
npm ERR!   errno: 3,
npm ERR!   code: 'EACCES',
npm ERR!   path: '/Users/DJ/.atom/.node-gyp/.atom' }
npm ERR! 
npm ERR! Please try running this command again as root/Administrator.

npm ERR! Please include the following file with any support request:
npm ERR!     /private/var/folders/dd/77s05wdn7qx2fpwwx8zphhl00000gn/T/apm-install-dir-114108-3031-exryck/npm-debug.log

#2

Do you have access to /Users/DJ/.atom?


#3

I’ve never heard of anyone needing to update their version of npm. I’d say that’s a red herring. I’ve been using the version packaged with Atom since February (currently 1.4.4) and it works fine.

Is the first error message the entire error? Can you include the npm-debug.log it mentions in the error message?


#4

@mark_hahn Yes I do. Heres is the current permissions.

server2:~ DJ$ ls -lad '.atom'
drwxr-xr-x  13 DJ  staff  442 Nov  8 13:32 .atom

@leedohm I can’t seen to find that file its describing below is live video.
Also, in my initial post I had posted my error report on the npm forum which by their suggestion on trying to upgrade the npm version to see if that might fix issues.
But not really sure what is going on whether if its a 10.10 mac issue because I can replicate this issue on multiple macs with 10.10.

npm 2.1.7 <-- updated this (REF https://github.com/npm/npm/issues/6613#event-1903941451)
http://youtu.be/KleqFOBlF7c


#5

No, it isn’t an OS X or Yosemite issue. I and multiple others are running Atom on Yosemite (with npm v1.4.4) without issue.

  • How are you installing Atom?
  • Where do you install Atom?

#6

@leedohm Good to know that it isn’t system mac related.

  • Using most recent build from https://atom.io/
  • Installed to /Applications/ folder on my mac

#7

In the video, the error mentions EACCES mkdir /Users/DJ/.atom/.node-gyp/.atom. It would appear that while you may have access to the ~/.atom directory itself … you don’t have access to create directories inside it? If that is the case, then this is a permissions issue.

What I would try is to:

  1. Completely exit all copies of Atom
  2. Go to the command prompt
  3. mv ~/.atom ~/.atom-backup
  4. Open your Applications folder
  5. Launch Atom from the icon

Perhaps when you first installed some packages you were running as Administrator and the permissions of some files/directories got messed up.


#8

@leedohm Yes that is what I ended up doing was stopping all atom instances, moving the .atom folder. running and installing a plugin. stopped atom again and then coped over all old data from old .atom folder to the newly created folder which fixed the issue.

Thank you!