[SOLVED] New install, Github login button doesn't work

New user and new install so sorry if this is easy,

Essentially, the Github login button doesn’t do anything after entering the token. Similar to this closed issue from March 2018 perhaps: https://github.com/atom/github/issues/1346

  • New user
  • Brand new install of Atom (1.34.0)
  • No pref changes
  • No customisations
  • No new packages downloaded
  • Never opened a project so didn’t try ‘clear saved state’ etc
  • Tried safe mode (atom --safe)

Connecting to Github was literally the first thing tried after installing - any suggestions welcome.

  • Atom: 1.34.0
  • Electron: 2.0.16
  • Chrome: 61.0.3163.100
  • Node: 8.9
  • Mac OSX 10.14

Can you open your developer console (by running “Window: Toggle Dev Tools” in the command palette) and share any errors that you see there?

Also: can you confirm that you’re entering a token generated from https://github.atom.io/login and not a “personal access token” from GitHub proper?

Thanks for the reply,

Yes, I’m clicking the link from the login window: https://github.atom.io/login

Here is the error I see in dev tools. I wasn’t asked for a username in Atom but obviously had to login to Github.

Uncaught (in promise) Error: Command failed: security add-generic-password -s atom-github -a https://api.github.com -w dc43b67c08f83807ba66801b58fde73c655299e0 -U
security: SecKeychainItemModifyContent: The user name or passphrase you entered is not correct.
security: SecKeychainItemCreateFromContent (<default>): The user name or passphrase you entered is not correct.

at ChildProcess.exithandler (child_process.js:287)
at emitTwo (events.js:126)
at ChildProcess.emit (events.js:214)
at maybeClose (internal/child_process.js:925)
at Process.ChildProcess._handle.onexit (internal/child_process.js:209)

Oh okay, thanks for the extra information. I see what’s going on but I’m unsure why.

Long story short: we use a native library called keytar to store credentials in your OS keychain. On macOS, if that isn’t working – the most common one we encounter is that it doesn’t work in our unsigned dev builds – we fall back to using the mac’s security command-line tool. For some reason this is being triggered on your machine, and security is failing because it can’t access your OS keychain.

You may be able to get things working by running this in a terminal, and providing your macOS login password:

security unlock-keychain

But, I’m not sure why:

  1. keytar isn’t working for you; and
  2. security isn’t able to write to your keychain already.
3 Likes

Running security unlock-keychain worked and was able to login in Atom.

Thanks for your time and help, much appreciated.