[Solved] Linter and Diagnostics not working


#1

I don’t know what to do but I can’t get the linter UI to show up at all, I don’t see the 0 : 0 : 0 or whatever for errors, warnings, etc.

I have linter installed, I have json lint installed.

I can open the contextual menu, type “lint”, get a bunch of options, but none of them do anything. I tried reinstalling atom and the packages, but it seems like I didn’t uninstall properly or something? I deleted the app and my “~/Library/Application Support/Atom” folder, but when I redownloaded the app, all my packages and custom settings still exist.

All I want, is for Atom to tell me when my JSON is invalid, however small the typo is, like an extra comma.
But I can’t get anything to give me these errors, I even tried Atom-IDE package and “diagnostics” but then Atom told me there are compatibility issues between Linter and Diagnostics, and one has to be turned off for the other to work BUT neither settings works for me…

Any help?


#2

What happens if you have atom-ide-ui and jsonlint enabled (and disable the other “linter” packages)?

You can also check dev tools for any errors it may be throwing.

EDIT: I mean linter-jsonlint, not jsonlint


#3

thank you that worked!

i was getting frustrated and probably forgot to try this configuration

and i was using linter-jsonlint package rather than jsonlint package, that’s probably what made it work


#4

Sorry, I did mean the linter-jsonlint package. I didn’t even realise there was a jsonlint package.

Can you clarify which one you were trying before, and which one worked? I’ve been using linter-jsonlint myself.


#5

Yeah funny how that worked out!

linter and linter-jsonlint did NOT work for me

jsonlint did