SOLVED: International keyboards not able to use backslash (\) in atom


#1

I’ve seen a lot of comments with people having this issue so I thought i’d share my solution here:

Open atom: Press CTRL-±. so CTRL PLUS DOT.
Next: type in the following: ctrl-alt-+{\}
save the file, and you’re done :slight_smile:


#2

Alternatively it’s likely an atom command clash with your key combo to make backslash.
You can find it and set it to unset.

this package helps a lot

and this thread cover the issue.


#3

You can use a double-backslash to prevent the escaping thing: {\}


#4

thx, updated the answer! Hopefully someone will navigate through this post sometime and find it useful :slight_smile:


#5

I am not sure what I am doing wrong, but I am still not able to type backslash.
I am using the Swedish Pro setting with an external “windows” keyboard.
Some guides tells me to use shift+alt+7, but that just opens the help menu in Atom (or in any application I am in).
In Windows, I used to push AltGr and + to get backslash.
The guy here tell me to press CTRL and +, but he types CTRL plus DOT? Very confusing.
In any case, pressing CTRL+. does not do anything att all. If I press WindowsKey + . it seems to bring up a key binder. Not sure if that is the one he is talking about, because it does not open any files that I can “save” as he is talking about. Can someone please provide a way that actually works? I assume he is re-binding the key, but a more detailed explanation would be nice…


#6

Ok! So here is the REAL solution! Stupid OS X has a built-in default keyboard shortcut that makes shift+alt+7 open the help menu!!! Go and turn that off in the settings:

System Preferences - Keyboard - Shortcuts - App Shortcuts - Show help menu

After that, you will be able to use shift+alt+7 to type \


#7

You’re mistaken. No that is not the solution to this issue (which has been resolved in later releases I believe), sure, OS X has that default binding, but that is not the issue here. OS X is context-aware so it doesn’t matter. also, what’s confusing about CTRL PLUS DOT. You press 3 keys. In that order…