[SOLVED] Fonts are not applied


#1

Atom 0.176.0 does not apply any fonts I specify in the Font Family field in Settings. The default or fall-back font remains in effect.

Font Size and Line Height update properly to the setting I specify.


#2

What OS version? Can you paste the output of apm list -i?


#3

I suspect you’re using Linux? You might want to check out these topics and see if they help:


#4

My apologies; I should have supplied this information.

OS: Mac OS X 10.10.1
Atom: v0.176.00

~/.atom/packages (27) ├── atom-flat-ui@1.1.0 ├── atom-light-simple-syntax@0.2.0 ├── atom-soda-dark-ui@0.8.0 ├── atom-square-light-ui@0.1.2 ├── auto-update-packages@0.2.2 ├── autocomplete-plus@2.0.2 ├── broadcast-theme@1.2.0 ├── cucumber@0.4.1 ├── cucumber-step@0.1.2 ├── envy-theme@0.1.1 ├── fantasy-ui@2.0.0 ├── file-icons@1.4.8 ├── file-type-icons@0.5.4 ├── fizzy@0.15.0 ├── flat-simple-dark-ui@0.1.1 ├── flatland-dark@0.1.3 ├── flatland-dark-ui@0.2.3 ├── git-plus@4.3.6 ├── jumpy@2.0.2 ├── markdown-format@2.5.0 ├── pdf-view@0.14.0 ├── proton@3.0.0 ├── proton-light@0.2.0 ├── seti-syntax@0.2.1 ├── seti-ui@0.6.3 ├── twilight@0.3.0 └── yosemite-unity-ui@0.3.13


#5

Do you still see the same issue in safe mode? (e.g. atom --safe .)


#6

Actually, in --safe mode, it’s fine. The font specified is correctly applied.


#7

Which themes do you have active?


#8

I believe the culprit was the Fizzy syntax theme. It was force-applying a particular font.

Now that I have switched to another syntax theme, I can specify my desired font.


#9

Ah good catch! Might be worth opening an issue on their repo.


#10

I shall do that and mark this issue as [solved].


#11

Cool :grinning: I’ll close this topic as resolved then.


#12