[Solved] Find References: Symbol references are not available for this project


#1

Hi,
can someone please help me?

public function getProgress() {
    $allResults = $this->results()->count();
    $doneResults = $this->results()->whereNotNull('result')->count();

    return round(($doneResults / $allResults) * 100);
}

When I position my cursor on “getProgress” and invoke “Find References: Activate” I expecteed it to show me a list of all the places, where that method is used.

Instead I get “Find References: Symbol references are not available for this project.”

So my questions are:

  1. Is my expectation wrong?

  2. Am I doing something wrong?

  3. Am I missing a package?

    Atom : 1.23.3
    Electron: 1.6.15
    Chrome : 56.0.2924.87
    Node : 7.4.0

    Community Packages (9)
    atom-beautify@0.30.9
    atom-ide-ui@0.8.1
    git-plus@7.10.0
    goto-definition@1.3.4
    language-blade@0.38.0
    linter-php@1.5.1
    php-integrator-autocomplete-plus@1.6.2 (disabled)
    php-integrator-base@3.2.1
    project-manager@3.3.5

Update Same effect with the current Beta

Atom    : 1.24.0-beta3
Electron: 1.6.15
Chrome  : 56.0.2924.87
Node    : 7.4.0

#2

It looks like you’re using PHP? I see you have the atom-ide-ui package installed but you also need to install a IDE language package as well. Go ahead and install ide-php and give it another try.


#3

Thanks a ton, @rsese!

That solved it. I was following this guide: https://php.earth/docs/interop/atom for atom+php and either I must have overlooked it or that guide is incomplete.

Anyway: Thanks again. You helped a lot moving me from jEdit to Atom.


#4

The guide you linked to doesn’t mention atom-ide-ui, or any other packages with ide in the name. I’m not sure where you got that particular package from, but I don’t think it was the guide.


#5

You are right @Aerijo. But this slack discussion wasn’t my first attempt in solving my issue. So I somehow found out that atom-ide-ui is required for having references.

I simply failed to find out that ide-php is also a prerequisit.