SOLVED - Fetching outdated packages and themes failed-


#1

Does anyone know why is this happening? I’ve been looking at several threads in the forum and haven’t found a solution.

This is the only feedback I get whenever I try to check for updates in the editor or with apm upgrade.

As expected, just undefined isn’t a really helpful log, so I was wondering if anyone else had this issue and knows how to solve it.

I’m using Atom on Ubuntu 16.04 and it is on version 1.14.2 x64.


New files open in the tree view area
SOLVED - Checking for Package Updates fails
#2

Hey, you’re not alone in your issue, though I’m sorry to see there have been no replies on possible fixes yet. Definitely a bit frustrating considering the non-actionable error output. As far as solution searching goes, this seems to be pretty recent or quite rare.

On Mac 10.12.3 and Atom v1.14.2 x64.


#3

I’ve got the same issue after upgrading to 1.42.2x64 on Windows 7 earlier today.


#4

Uninstall seti-syntax/seti-ui.

Found this answer at https://github.com/atom/atom/issues/13804


#5

Can confirm that this worked for me. I uninstalled both seti ui and syntax via GUI, restarted Atom, and updates started working again. Thanks for the quick fix ballew!


#6

I had that same issue with 1.15.beta - and uninstalling seti ui & seti syntax fixed it.


#7

Whoa. I just tried that and it worked! And I don’t even use those themes anymore for months now.

Thanks!


#8

Worked for me as well - MacOS Siera 10.12.3 Atom 1.14.2 x64


#9

The same for me. Same error and when i uninstalled this themes…all works fine again.
Thanks for sharing the experience…:slight_smile:


#10

+1 worked for me. Thx :slight_smile:


#11

+1 here as well, confirmed for Atom 1.14.3 x64 on macOS 10.12.2


#12

+1 This was bothering me for weeks. Stumbled on the solution by accident. Very weird.


#13

Can confirm this solution.


#14

Boom! :punch: Worked!!


#15

Also noticed it had been a week or two since had any updates (eror mssg. was different) but removing seti and restarting fixed the issue (16 updates ready after restart).


#16

Same here. Remove Seti UI & syntax fixed this issue.


#17

Thank you! I’ve been having this issue for months on my Windows 7 Professional machine. No issues with my Windows 10, Linux (Fedora 25), and MacOS machines. I wasn’t even using Seti anyway so this was a easy fix.


#18

Confirmed!


#19

Uninstalling seti-syntax/seti-ui worked for me as well


#20

Strange, why have they not fixed the Seti Syntax theme? Deleting it worked for me and I was able to update. I’ve had this problem for months and haven’t noticed. Which makes me wonder if my linting packages were possibly not working and I could have introduced bug. This is not good. Someone should remove the Seti Syntax theme and never let it back!!!