[SOLVED] Electron freezes (devtools too) when refreshing window. Any ideas?

I upgraded from Electron v4 to v10 yesterday.

Everything is working great, except if I hit ctrl-r to refresh the window: in that case Electron freezes. At this point Devtools will no longer do anything (executing an expression in the console does nothing, hitting the pause button in the Sources tab doesn’t do anything, etc). The devtools UI is responsive, but it just doesn’t do anything (as if it is waiting for the JS context or something).

It’s just completely hung, with no errors in devtools (and nothing works).

Any ideas what to check?

Ah, I ran electron with ELECTRON_ENABLE_LOGGING=true, and in the terminal I see an output that I don’t see in devtools:

(node:73342) WARNING: Waiting for queued ZeroMQ messages to be delivered. Set 'context.blocky = false' to change this behaviour.

That’s the last message I see while everything is frozen. I think that might be the issue.

I opened an issue on ZeroMQ.js.