[solved] Atom keeps freezing when opening one specific project


#1

Hi there,

Within one of my projects, I accidentally tried to open a Word file in Atom (whoops…). Needless to say, that did not go very smooth, and I had to restart Atom because the “Editor is not responding”.

But ever since, every time I try to open the project in which this mistake happened, Atom freezes and keeps saying “Editor is not responding”. But this only happens for this specific project, not for other projects that I open with “File” > “Open Folder”. So, only when I try to open that specific project with “File” > “Open Folder”.

I’m not sure what’s going on, or how I can solve it. Could anyone help me out with this problem? I disabled all of the packages that I manually installed, for what it’s worth. I’m running Atom on Windows 10.


#2

You can open Atom from the command line with atom --clear-saved-state and it will forget all of the tabs you had open.


#3

Thanks for the heads up. I tried it immediately, but it did not work… All the open tabs are still there.

I now notice that the code highlighting stops after a few lines of code, and even though the scrollbars indicate a top-left scroll offset, the visible area does not start at line 0, nor is it at col 0…

Apart from that, no improvement so far…


#4

I’m dumb and gave you the wrong answer. It’s atom --clear-window-state. I should have checked the docs, but I said what was on the top of my head and it was wrong.


#5

Ok, thanks. I’ll try it tomorrow! :slight_smile:


#6

Alright, thanks man! It worked! Now I’m able to open any project without freezing! :slight_smile:


#7

How big is the file you are opening? I have had this issue when using very large files.


#8

I guess the problem why Atom froze, was the fact I accidentally opened a non-supported file type: Microsoft Word’s doc file type. The doc file in question was only 29kb big. Besides, I think that there is hardly any file in the project folder in question that is bigger than ~1MB.

So I guess for me, the problem wasn’t the file size, but a file type that Atom could not read. And somehow, Atom got stuck with reading that file within the project folder. So for me, clearing any cached settings with --clear-window-state worked like a charm! :slight_smile:

I guess this topic can be regarded solved. Since @DamnedScholar provided a working solution already… :wink: