Soft wrap support, but only for Markdown?


#1

I was wondering if there’s a way to configure “Soft Wrap at Preferred Length,” but only for Markdown files? I like to have my prose neat and tidy in one column, but don’t mind my code to run past the line length occasionally.

Thanks in advance!


How do I turn off soft wrap?
#2

Hello.

Make a change in your “config.cson” file… reached via FILE >> CONFIG.

"*":
  editor:
    softWrap: false  # the rule

".md.text":  # when available
  editor:
    softWrap: true  # the exception #1

".gfm.source":  # the default: github version
  editor:
    softWrap: true  # the exception #2

#3

The documentation of this feature (and how to find out the scope descriptors to use) is in the Atom Flight Manual:

http://flight-manual.atom.io/using-atom/sections/basic-customization/#language-specific-configuration-settings


#4

Thank you!