Soft wrap + max screen line length options not respected


#1

I have soft warp turned off and max screen line length set to 10000.

Nevertheless, my lines keep wrapping at the edge of the window, well before I hit 10000 characters. I think this might be a bug.


#2

If you set Settings > Editor > Preferred Line Length to 10000 and check Settings > Editor > Soft Wrap At Preferred Line Length, things should work like you want.


#3

I see how that would fix the issue, but my preferred line length isn’t 10000, and I’d like to keep the little line that vertical line in the editor that tells me when I’ve reached 80 chars. Isn’t there some way I can change this without messing up my preferred line length?


#4

Oh sorry I think I misunderstood you - so you have soft-wrap disabled but wrapping is happening with the window width?

I just tested with Max Screen Line Length set to 700 and it’s working correctly - with soft-wrap disabled, I don’t see wrapping till I go over 700. Can you confirm if things work for you if you try this?