Soft Wrap broken?


#1

I’m using Atom on Linux and since the beginning the soft wrap is unusable.
see below, both the soft wrap alone and the soft wrap at X characters:

is there anything I’m missing?


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

#3

Hi @leedohm, I’m using 1.5.3 on ArchLinux
I’ve tried to start it with --safe option but nothing has really changed.


#4

Is it just that specific file that is running into a problem? Or is it all files?


#5

@leedohm, I’ve never noticed it working on any file.


#6

also, just to be clear: the initial screenshot was with “soft wrap” and “soft wrap at preferred line length” options ticked.

The following is just with the “soft wrap” ticket.


#7

I can’t reproduce that behavior no matter how I have Soft Wrap set. Though I’m using OS X, not ArchLinux.


#8

would be there anything more I can provide to help find the source of this problem?


#9

There may be. I just don’t know what that is :frowning: You should file a bug on https://github.com/atom/atom (probably search to see if this is already reported).


#10

@leedohm @ThePeach I experienced the same bug after I installed a new atom (v1.5.3) installation.
The ‘Soft Wrap Hanging Indent’ happened to be somehow set to ‘80’ by default (which clearly is meant to be ‘Preferred Line Length’, which is correctly set to ‘80’ by default.)

Solution: Go to Settings -> Change Soft Wrap Hanging Indent to 2 (maybe, or anything of your preference)

@ThePeach You might not have been able to recreate it probably because yours wasn’t a fresh intallation but an upgrade from previous installation.


#11

@sarojkh: mind blown!

Oh jeez that seems to be a problem inherited by an old build I had… Now if I remove the value I had there the default value shown is 0 which is indeed what was needed.

Thanks a lot, I consider this as solved.