Soft vs Hard tabs settings make no sense


#1

First, my opinion, since I am so passionate about tabs versus spaces: it should be dead easy to say

a) I want tabs
b) I want spaces

Secondly, after 30 minutes, I finally got tabs to work as tabs and not spaces. The sequence for this makes 0 sense. Here is how you get tabs as tabs instead of spaces in Atom.

  1. Go to File > Settings > Editor
  2. Uncheck Soft Tabs
  3. Set Tab Type to “Hard”
    Create a new file, notice that tab still = 2 spaces.
  4. Uncheck Atomic Soft Tabs?
    Tab still = 2 spaces
  5. Change Tab Length to 4 “spaces”
    Tab now seems to be 4 spaces, but,
  6. Copy-paste code into hex editor, “4 spaces” is actually a tab character.

Come on…


#2

Do you have Show Invisibles on? I would expect Step 3 to start showing a bunch of greyed-out » characters, which means that the “spaces” at the start of the line are the indentation of a tab. And when I test it, that’s exactly what I see. You also don’t need any other step; like the Soft Tabs checkbox says, it is overridden by the Tab Type setting.