Soft Tabs in Markdown File


#1

I was using atom when I tried to change three things:

  1. Typeface
  2. Font-Size
  3. Soft tab behaviour.

Now, every programmer has their own opinions on how tabs should be handled. I personally don’t like soft tabs so I turned them off. But now when I’m editing my Markdown file I only get soft tabs, which I know for sure wasn’t the behaviour I was experiencing earlier. I would like to get only hard tabs in my file going forward.

Is there anything I can post that would help get to the bottom of this problem, like log files, init scripts, or package lists?


#2

Do you have Tab Type set to “hard” in your Settings View?

If it is set to “auto” it will attempt to autodetect and only use the Soft Tabs setting if it “can’t figure it out”.


#3

Ah thank you so much. I should have been able to figure that out.