Snippets in SCSS Not Triggering


#1

I very often use block comments to designate sections within a file and can’t seem to get an SCSS comment block working.

'.source.scss':
'SCSS Comment':
'prefix': '// '
'body': '// ------------------------------------------------------------------- //\n//\n// ------------------------------------------------------------------- //\n$

The desired outcome:

// ------------------------------------------------------------------- //
//  Module A: Blog Listing
// ------------------------------------------------------------------- //

I’ve tried using .text.scss and replacing .scss with .sass but no luck. Are snippets in SCSS supported? Lots of topics related to snippets mention they really only work in HTML/CSS/JQ right now.


#2

Hey Geebru,

I’ve had the same issue, except with using .source.less. Just disabled emmet and found it works now. I’d try the same. It’s sucks because it’s kind of a tradeoff but I honestly use snippets more than emmet. I wish I didn’t have to though because I lose a few cool features. If anyone has a solution besides this, I’d like to know.


#3

I’m having the same issue. Snippets that trigger in normal css files are not triggering in .scss files. I don’t have emmet installed so @masoninthesis’s solution hasn’t worked for me.

Is anyone else experiencing this issue and have the found a solution?

Thanks.

Edit: If I change the grammar of my .scss files to css then the snippets work but then you don’t get syntax highlighting for sass.

Edit2: My custom snippets seem to be working now. Sorry for the unnecessary comment.


#4

Memo
I can resolve this:

'.source.css.scss':
  'comment':
    'prefix': 'comment'
    'body': '// -----------------\n' +
            '// $0\n' +
            '// -----------------\n';

#5

This one solved the problem !
Thanks !


#6

@masoninthesis thank you for pointing out that it’s Emmet overriding the built-in snippets! That solved my problem. I just wanted to add that you can make snippets in Emmet, if you want to have your cake and eat it too:

https://docs.emmet.io/customization/snippets/