Snippets have stopped working


#1

I have been using Atom for some time. Recently two packages needed updates and it seems that since then my Snippets have stopped working.

I had just setup some custom snippets and they were working fine and then they all stopped.

The basic snippet of ! + tab does nothing now.

Any ideas how to fix this?

Dan


#2

Update: The snippets do work in one file but not in any new files. I must not understand how Snippets are suppose to work.


#3

See what this does:


Trigger FILE with Alt+f.

PS - which programming language were you busy with?


#4

Thanks for the reply. This setting was set. I turned it off. No change in behaviour.


#5

Both files have php extensions. I have tried setting the grammar to php and html but the results are the same. The snippets work in one but not the other. I created the second file by duplicating the first.


#6

Mind sharing a screenshot of the snippets in question, as well as one with both files open?


#7

Not at all. Here is the first shot.

This one shows how when I type bu it brings up the list of snippets available.

Dan


#8

Here is the second shot.

Here all I have done is change files. You can see at the top it is just another php file. Now when I type bu I get a different set of available snippets.

Dan


#9

And now I see that the Grammar did change from one file to the next. When I set the grammar to php the snippets do work.

Damn. I could have sworn I had checked that already.

Sorry for the waste of time.


#10

It’s fine. That’s why I wanted to see each of the files, because almost always this sort of issue can be resolved just by someone with more experience looking at the screen and seeing what information was missed.