Snippets are killing me


#1

I know other people have asked this before, but seriously isn’t there a way to disable ALL snippets?

Autocompletion of single words are great, but it is quite infuriating to write models in rails when every time I write “.id” it gets replaced with "# IDEA: " unless I am careful not to hit enter. And it is far from the only example.

Every answer I have come upon has been something like “You can override each one manually” which is just not an option…

In my experience this is a flaw that makes the daily use of this otherwise awesome product extremely aggrevating at times. And all it takes is a disable button.

In any case, do anyone have a hack or something?


#2

There are two packages: snippets and autocomplete-snippets that you can disable from the settings-view packages tab. autocomplete-snippets is the package that adds snippets to the autocomplete+ suggestions.


#3

You are now my hero! Thanks :smiley: