Small lag spikes occur when typing text [Solved]


#1

Whenever typing into the editor, around every 10 seconds a 5 second lag spike occurs. (The screen freezes for a few seconds.) It happens in safe mode, and I do not have any packages or themes installed. Any idea as to why this happens?


#2

What version of Atom are you running? In the lower right-hand corner of the window, do you see a large number of files being tracked?


#3

So this is what I see when I do atom --version:

Atom    : 1.20.1
Electron: 1.6.9
Chrome  : 56.0.2924.87
Node    : 7.4.0

And to answer your second question, I see a VERY large number of files being tracked.
36 PM


#4

To fix it, restart Atom. It will upgrade to 1.21 and the problem will be fixed.

There’s a directory named .git/ in some high-level folder, probably your home folder. 1.21 included a fix where Atom doesn’t pay attention to those any more. You probably didn’t put it there on purpose and should be able to safely delete it.


#5

That worked, thank you!


#6

The problem is occurring again. I am on version 1.21.1 and no large amount of files are being tracked. It happens in safe mode too.


#7

Just to be triple-certain, you could disable the github package.

Safe mode eliminates all community packages and your init script. At that point, the possible culprits are Atom itself (a bug), Atom’s core packages, the files you have open, and your computer (since Atom isn’t a small program, it’s possible for it to encumber older processors and memory, especially if other stuff is going on; this is something that I encountered a lot on my most recent laptop before I upgraded). I can’t do anything except suggest problems that I know to be common, and with the information I have, I’ve exhausted my ideas. At this point, you should try deleting Atom completely and reinstalling.

If you believe this to be a bug in Atom, you should open an issue on the GitHub repo with as much information as you can think of. Right now, there’s not enough information to start triangulating the source of the problem, but if someone else has experienced a similar symptom, then maybe something can be learned by comparing the two cases.


#8

Alright. I am marking it as solved, however it really isn’t yet. Thanks!


#9

Don’t mark as solved, I’m having this problem as well in 1.21.1. Super bad cursor lag when typing or when moving my cursor forward/back using arrow keys.


#10

Does this happen when you open Atom from the command line with atom --safe? Does it happen when you don’t have any large files open? What operating system are you running? Do you observe any spikes in CPU or memory usage when this happens?


#11

This is also happening for me in atom 1.21.1 since the last update. Running in safe mode doesnt fix the problem. Is there a github package under core packages? If so I dont see it, but I assume thats the culprit because last time I had a problem like this it was github.


#12

There is. What operating system are you on and how was the problem solved last time?


#13

Im on Arch Linux. Last time I cant remember exactly what package I disabled but it was a git related package that tracks your files. For now I just downgraded to 1.20.1 and the problem is fixed.


#14

Like the github package that you say you can’t find? What was the problem last time? If you had github disabled, then it’s unlikely to be the same thing.

For now I just downgraded to 1.20.1 and the problem is fixed.

That doesn’t do anything to help us figure out why 1.21.0 causes you problems. If this is a persistent bug of some sort and nobody identifies what it is, then it’s not going to get fixed.


#15

I didn’t realize atom puts disabled packages at the bottom of the list so that’s why I didn’t see it. It turns out I did have github disabled, so that must have been the “git related package” I was talking about. I disabled it a long time ago because it was making atom extremely slow because of its file tracking.

You are right, something else besides github seems to be the culprit this time.


#16

The problem with it that I’m aware of was specifically caused by a .git directory being where it shouldn’t have been and was easy to identify (there were an absurdly large number of files tracked). That was fixed in the version bundled with 1.21.0.


#17

Running MacOS 10.13. No spikes in CPU or RAM usage. I’ll check in safe mode when I have a chance. Problem just started for me when Atom updated (from 1.20.? to 1.21.1).


#18

Can people who are still experiencing lag on Atom 1.21.1 try installing Atom 1.21.0 and report back if the lag continues?


#19

Is that easy or is it a pain in the ass?


#20

Download 1.21.0, then go to Help -> About Atom and uncheck “Automatically download updates”.