Shortcut for folding code


#1

I have a odd problem in the code panel. I can not write character [ or ], thus making it impossible to code. I use a French Canadian keyboard and my [ and ] are done by pressing ALTCAR + ^ and ALTCAR + ¸. Instead of writing the character it does code (un)folding. Same as I’d pressed CTRL + ALT + [ and CTRL + ALT + ].

How can I remove fold/unfold shortcut so I can write [ and ]

P.S. Using Official Windows build v0.113.0


#2

Try this

  • Type ctrl-shift-P
  • Type stylesheet
  • Select Application: Open Your Stylesheet

Add the following:

'.workspace .editor:not(.mini)':
  'ctrl-alt-[': 'unset!'
  'ctrl-alt-]': 'unset!'
  'ctrl-alt-{': 'unset!'
  'ctrl-alt-}': 'unset!'
  • File -> Save

#4

Thank you, it worked!


#5

Actually is still doesn’t work…


#6

Related to this issue https://github.com/atom/atom/issues/1625


#7

On Windows 10, I had to add .platform-win32 to make it works on Atom 1.9.8. I also use French Canadian keyboard.

'.platform-win32 .editor':
  'ctrl-alt-[': 'unset!'
  'ctrl-alt-]': 'unset!'

Thanks to @juniorgodoi, Disable default keybindings