Shift back end tag when placing end bracket


#1

Hello, I have a copy of Atom on my computer and I’m trying to get elements to shift back the way they do on my school PCs.

What happens on my school PCs is that when I input the closing bracket of an end tag, it automatically shifts back to be aligned with the start tag, e.g.
<head>
</head>

But what happens on my PC is that even after inputting the closing bracket, the end tag still appears one space ahead of the start tag, e.g.

<head>
~</head>
(Pretend the tilde is an empty space)

Can anyone help me with this please? Having this difference is disorienting to me. Thanks!


#2

This is something that should just happen, because it’s controlled by the settings built into the core package language-html. The only reasons I can think of why the de-indent function wouldn’t work automatically is if you have something weird in config.cson to override it, or you’re using a different language package.

On your home computer, open Atom from the command line with atom --safe and tell me if it works then.


#3

@ByteMega:
Hello.

Please have a look at the version numbers of the software you have vs. the school has.
Next have a look at what you have on the configuration setting:
image

On my Atom version (V1.34), I get the result you speak of when Tree Sitter Parser is switched on. What you see at school is replicated on my Atom when Tree Sitter Parser is switched off. So you can switch Tree Sitter Parser off.

Alternate is to use the built-in autocompletes. Start by typing head and then Tab to activate the autocomplete. There were some Atom version where this was broken, so the most current version is recommended. Visit https://atom.io to get your copy.

BR


#4

Thank you all for your replies! I tried the solution danPadric suggested and it worked out fine.