SFTP atom remote

Dear supporters,

I run tow linux Ubuntu machines, one local, the one I work from and the other remote where the python script is located. Lately I’ve be trying to configure remote sftp editing with a config file. In general I connect to my remote machine using ssh/sftp no password only key exchange. It works flawlessly.

I have issues configuring the setup/config file in atom. I think the problem has to do with understanding pass, private key and passphrase. Any suggestion on help would be appreciated. Topic search here seems not to give adequate answers.

I am also on a local Ubuntu 20.04 desktop and rather than experimenting with different packages to upload to various sites I tend to roll my own custom processes to connect to remote assets. The single Atom gateway I use for this is process-palette package. Once you master how to use it you can setup Atom to pass various arguments (ProjectPath, FilePath) to other tools in a toolchain such as rsync, PuTTY, FileZilla or just the command line. PuTTY for example can operate via command line. Get these tools to work first through gnome-terminal without using Atom and then you can connect their sessions through custom processes.
I use the “create menu” option in each custom process since it is too easy to have key conflicts.

P.S. another method I use is to place Krusader twin panel file manager before Atom and I can use Krusader UserActions to push project folders into Atom.

So the toolchain becomes …

Krusader >> UserActions >> Atom >> process-palette >> PuTTY or FileZilla >. Remote server(s)

My remote Ubuntu is configured with running shh server. Ssh is configured with password login disabled.
ssh key enabled. I would like to keep it that way but considering enabling password login in order to experiment with atom. In atom I use Remote FTP to setup sftp.

I just follow and replicate processes in guides like this one. << click link

Thanks d_l. I finally made it work. And here follows my config file:

{
“protocol”: “sftp”,
“host”: “xxx.xxx.xxx.xxx”,
“port”: xx,
“user”: “xxxx”,
“pass”: “false”,
“promptForPass”: false,
“remote”: “/home/xxx/xxx/xxx/xxx/xxxx/”,
“local”: “/home/xxx/xxxx/xxx/xxxx/xxxx/”,
“privatekey”: “~/.ssh/id_rsa”
}